Microsoft Releases Reliability Patch For IE11

6

Microsoft has released a reliability update for Internet Explorer 11 that applies to the following operating systems:

•Windows 8.1
•Windows 8.1 Enterprise
•Windows 8.1 Pro
•Windows RT 8.1
•Windows Server 2012 R2 Datacenter
•Windows Server 2012 R2 Essentials
•Windows Server 2012 R2 Foundation
•Windows Server 2012 R2 Standard

Details regarding what the patch fixes exactly are not available at this time, but the patch is available through Windows Update.  You cannot install this patch if you are running the Windows 8.1 Preview.

Source: Microsoft



About Author

Suril is a scientist, journalist and obsessive Microsoft observer. He holds an advanced degree in Biotechnology with minors in Biochemistry, Microbiology, and Molecular Biology. Send him tips on twitter: http://www.twitter.com/surilamin

  • Bugbog

    Was just thinking that this should be coming soon!

    I think it’s for the slight manner in which IE11 is slightly unstable (slight freezes) which, in turn, pass the effect on to the main system sometimes.

    Update: And they’ve all updated [silently] in the background!

    • Johan Spånberg

      Yeah! I’m having a couple of crashes (disappears) randomly while Reading comments on different sites. Hopefully this will fix that.

  • FateStayNight

    Went into a no-boot situation after the patch. I didn’t turn on system restore because I thought it was only going to change IE, but after the patch the computer can’t boot up and can’t be fixed by system recovery. Had to manually extract files from the source and replace the missing/corrupted ones in the OS. Took me half a day. Lesson : always turn on system restore hahaha :)

  • elpadr1no

    Couldn’t have come at a better time. Metro IE works fine but Desktop IE was giving me headaches.

  • John Scott

    Lot’s of issues with IE 11. Tried the beta on Windows 7 and had to go back to IE 10. Like the performance when it was working.

    • reKitab

      You’re not alone: I “Tried the beta on Windows 7 and had to go back to IE 10″ too:(